Creating sequences with custom animation

By default graphics in PowerPoint appear in one piece when the slide appears. Even if Preset Text Animation has been chosen in the Slide Sorter view, only text created by the Autotemplates with text blocks will be affected by that animation. In order to have slides develop sequentially we have to use the Custom Animation command under the Slide Show menu or on the task pane menu.

Animation is an unfortunate choice of terminology for this function. Although some effects do include movement, the idea is to sequentially present material for better understanding. Inappropriate use of movement effects can create a distraction from the development of a concept, or create a misleading impression.

The custom animation functions have changed significantly with various versions of PowerPoint.

Custom animation in Powerpoint 97, and 2000, (Windows) and 98 (Macintosh) as well as the Free downloadable viewers for both Platforms are identical.

The Macintosh versions 2001 and X are identical and include exit events that will not play back in previous versions. Those events will not play back in Powerpoint 2002, but will in Powerpoint 2004.

Powerpoint 2002 (part of Windows Office XP) added emphasis, exit, and motion path events as well as many new effects that will not play back in any previous version.

Powerpoint 2004 on the Macintosh added emphasis and exit events that will play back on the Windows version 2002.

Custom Animation and grouping

We want the graphic just created in the drawing tools section to appear in the following sequence.

The file can be downloaded from http://idea.uwosh.edu/nick/handouts.htm

As with everything else, groups are treated as a single object. When this graphic was created the three circles were created in several groups. In order to create the above sequence, some ungrouping and creating new groups needs to be done.

In Powerpoint 2002 you can ensure compatibility by turning off the new features. Custom animation is then exactly the same as in earlier versions. See page 55.

Powerpoint 2004 includes a compatibility checker that warns you about potential problems.
Ungrouping, selecting and grouping

When ungrouping objects and forming them into other groups, be careful not to move them.

If you do accidentally move them, choose Undo from the Edit menu. Powerpoint will undo up to that last ten actions.

Keep in mind that many groups are formed by grouping groups of objects, so in order to put things into the groups you need you may have to repeat the Ungroup command several times.

In the example, the top two circles are grouped together, that group is grouped with the bottom circle, and that group is grouped with the object that forms their intersection, so to get down to the individual circles (so you can group them together with their labels) you would have to ungroup three times.

In order to select multiple objects so you can group them together, hold down the Shift key while selecting objects, or surround them with a selection rectangle by clicking on the background near the object, holding down the mouse button and dragging the dotted rectangle until it surrounds all the objects you want to select.

If an extra object gets inadvertently selected, you can deselect that one by holding down the shift key and clicking on it, or by surrounding just that object with the shift key held down.

When you have all the objects selected that you want to form the group, choose Group from the top of the Draw menu.

Grouping can affect layering order

One complication of grouping to determine the order we want things to appear is the layering of objects. As we created the graphic, the word “Power” is above the circles, but in order for it to appear that the intersection is just filled, the Intersection object has to be behind the circles. When objects are grouped, they both become placed on the same layer. This shows the faceting of the intersection object. We can make them appear at the same time with just one mouse click, so just leave them ungrouped.

Often a Group entering a slide will look different than the same objects appearing individually at the same time, especially with motion effects.
The Custom animation interface in Powerpoint 2002 (Windows)

The new Custom Animation interface consists of the editable slide view and a task pane.

To access it, select Custom Animation from the Slide Show menu, or Custom Animation off the task pane menu.

Different types of events can be assigned to an object.

**Entrance** the object appears when the event occurs

**Emphasis** an object already on the slide changes to draw attention to itself

**Exit** the object leaves the slide.

**Motion Paths** the object moves from one place on the slide to another.

Using the group and ungroup functions on the Draw menu on the Drawing toolbar, you can make multiple objects behave as one, or divide some graphics which have been grouped into component parts.
As you continue to place objects in the animation order, objects on the slide are labeled with the number of the event they have been assigned.

Note that an object can have several events assigned to it. In this example, Group 3 is assigned both event 1 and part of event 6.

If the auto-preview box is checked, you will see a preview of the effect when you select it, or you can click the Play button when you’re ready.

There are three ways an event can be initiated.

- **On Click.** The event will occur when you click the mouse.
- **With Previous.** The event will occur at the same time as the previous event in the order, as in event 6 in the above example.
- **After previous.** The event will occur after a specified time interval. You can use this to set up automatically running sequences.

Events which occur *With Previous* can be different types of events with different effects.

In this illustration, Event 3 consists of Group 3 exiting on a mouse click, and Group 6 being emphasized and Group 9 entering all at the same time.
The Custom animation interface in Powerpoint 2004 (Macintosh)

In order to access custom animation in version 2004, select Custom Animation, under the slide show menu or click Custom animation in the Animation section of the Task Pane.

A list of objects on the slide will appear in left window. Select an object. It will appear selected in the miniature view below the list.

(If you select an item on the slide and then choose Custom Animation, it will be selected on the list when the dialogue box appears)

Click the Add Effect button. Choose the type of event and an effect and click OK.

After an effect is selected, it will appear in the Animation order. You can select how the event will be initiated in the slide show.

On Click. The event will occur when you click the mouse.

With Previous. The event will occur at the same time as the previous event in the order as in event 6 in the above example

After previous. The event will occur after a specified time interval. You can use this to set up automatically running sequences.

If show preview is checked, you will see a preview of the effect when it is selected

To remove an object from the order, select it and click the red X
Setting times for automatic advance or other timing options.

If you've chosen After previous in order to create sequences which automatically advance on time, you'll have to set the amount of time after the previous event. In 2002 (Windows), pull down the menu at the right side of the object and select Timing.

In 2004 (Macintosh) select the object and click the Effect Options button and select Timing.

There are several settings.

Start: You can change to On Click or with previous

Delay: You can set the time after the previous event this event will occur.

Speed: You can set how long the effect will take to occur.

Repeat: You can set the event to repeat. Probably only useful with emphasis events, e.g. to make a wheel rotate three times.

Most effects can be modified to change the direction, or amount with which they occur in the Property menu (this may be labeled differently depending on the effect you're working with—in the Windows example shown here, it's labeled Direction when the Fly-in effect is used).

There is also a menu to modify the speed at which an effect occur.

Other variations may be available by choosing the effects.
Changing the event type or effect for an event

In the Windows version when an object/event already in the animation order is selected, the Add Effect button changes to Change with which you can change the effect for that object/event to a different one, in exactly the same manner you assigned the effect in the first place.

In the Macintosh version, double click on the object/event in the animation order and the Event/Effects list will reappear.

When a bulleted list text object is placed in the animation order, by default, each 1st level bullet point is displayed along with any subpoints associated with it. If you had added an animation scheme to a slide, it would appear in the custom animation order in this way.

Notice that even though only one text block appears in the animation order, the first bullet point is labeled as event 1, the second and all its associated points are labeled as event 2, and the last is labeled event 3. They are grouped with their first level paragraph.
Changing how bullet points are grouped is the main option for text blocks. You can choose to display subpoints with the main point they are associated with (By 1st level paragraphs) or break it down so that lower level points are displayed individually. (By second or lower level paragraphs, depending on the outline levels in your text block)

![Animation Order and Custom Effects](image)

When you select a text block in the animation order, a double arrow appears at the lower left of item. If you click on this arrow, all elements of the text block appear and you can customize how they appear and even assign different effects to each point or change the order in which they appear.

![Sequence Modification](image)

If the text effect had been applied to the Master Slide, the menu that drops down gives you the option of copying the effects to the individual slide you’re working on so you can modify them for that individual slide, or lets you access the Slide Master to modify the effect, which will change all slides created from that Master.
Modifying the sequencing of text blocks (Macintosh)

When you place a text object with multiple paragraphs in the animation order, by default it appears grouped by first level paragraphs. Each paragraph is listed in animation order with the start setting set appropriately for each line.

In this example, the first two lines are first level paragraphs and set to start On Click, the last two are second level and are set to start With Previous, the first level paragraph they are under.

Clicking the Effect Options button will display a dialogue box. Select the Text Animation part and you can change the grouping of the text object.

By just selecting the individual lines in the Animation Order and changing their attributes you could modify this grouping or even change the effect or order in which they appear.
Changing the animation order (Windows)

You can change the order an event occurs by clicking on the event and dragging up or down. A dark line will appear where you have dragged to. When you release the mouse button, the order of the events will change.

You can also change the order of events by selecting an event and clicking the up or down Re-Order arrows at the bottom of the list.

Changing the animation order (Macintosh)

You can change the order of events by selecting an event and clicking the up or down arrows to the left of the list.
Powerpoint 2002 in Office XP has a completely new interface for setting up sequences and some powerful new animation features including exit events and moving an object from one location to another on the slide. If you use these features, and then play back the presentation in a previous version of Powerpoint, the events which utilize new features will simply not occur, and the program will jump to the next event.

In order to make sure you are creating presentations which are compatible with all versions (back to ’97), you can turn off the new features and use the older interface (This includes all versions of the stand alone Player).

Powerpoint 2001 and Powerpoint for OSX (Macintosh) include Exit events in Custom Animation that will not play back when played in previous versions, or in Powerpoint 2002. They have no option for turning them off.

Under the Tools menu is an Options... command

There are several panels in the Options dialogue. At the bottom under Disable new features is a check box for New animation effects. When it is checked, the Custom Animation dialogue is the same as earlier versions of Powerpoint, and new effects and events cannot be applied.

Sequences set up with the new interface will work when played back in an older version, as long as they don’t use any of the new effects. The only way to check compatibility is to actually try it in an older version. If you set up a sequence with the new interface, using new effects, and then disable the New animation effects, the presentation will still play with the new features in PowerPoint 2002.
Creating sequences with custom animation

The older version of custom animation

Normally graphics in PowerPoint appear in one piece when the slide appears. Even if Preset Text Animation has been chosen in the Slide Sorter view, only text created by the Autotemplates with text blocks will be affected by that animation. In order to have slides develop sequentially we have to use the Custom Animation command under the Slide Show menu.

Animation is an unfortunate choice of terminology for this function. Although some effects do include movement, the idea is to sequentially present material for better understanding. Inappropriate use of movement effects can create a distraction from the development of a concept, or create a misleading impression.

Using the Custom Animation dialogue

We want the graphic just created in the drawing tools section to appear in the following sequence.

The file can be downloaded from http://idea.uwosh.edu/nick/handouts.htm

The dialogue box which appears has several layers—If Order & Timing is not on top, click on the tab to bring it to the front. The upper left window lists all the elements on the slide, including the title and any text blocks created by the autotemplates.

Those elements not in the animation order will appear at the slide transition.

In order to have several objects appear at the same time they must be grouped together.

In order to have objects come in separately they cannot be grouped together.

In order to create the sequence we want, we will have to change the groups that were made when this graphic was created.
**Ungrouping, selecting and grouping**

When ungrouping objects and forming them into other groups, be careful not to move them. If you do accidentally move them, choose Undo from the Edit menu. PowerPoint will undo up to that last ten actions.

Keep in mind that many groups are formed by grouping groups of objects, so in order to put things into the groups you need you may have to repeat the Ungroup command several times.

In the example, the top two circles are grouped together, that group is grouped with the bottom circle, and that group is grouped with the object that forms their intersection, so to get down to the individual circles (so you can group them together with their labels) you would have to ungroup three times.

In order to select multiple objects so you can group them together, hold down the Shift key while selecting objects, or surround them with a selection rectangle by clicking on the background near the object, holding down the mouse button and dragging the dotted rectangle until it surrounds all the objects you want to select.

If an extra object gets inadvertently selected, you can deselect that one by holding down the shift key and clicking on it, or by surrounding just that object with the shift key held down.

When you have all the objects selected that you want to form the group, choose Group from the top of the Draw menu.

**Grouping can affect layering order**

One complication of grouping to determine the order we want things to appear is the layering of objects. As we created the graphic, the word “Power” is above the circles, but in order for it to appear that the intersection is just filled, the Intersection object has to be behind the circles. When objects are grouped, they both become placed on the same layer. This shows the faceting of the intersection object. So we can’t make these two appear simultaneously. We can make them appear one after the other with just one mouse click, so just leave them ungrouped for now.
Creating sequences with custom animation

Moving objects into the Animation Order

The intersection object
The upper left circle and “Group”
The upper right circle and “Align”
The bottom circle and “Layer”
“Power”

Scroll down to find the paragraph (Text 7)

Now the objects appear in the list as the groups you want to enter the slide. They appear on this list in the order they were created. You will have to determine the order they will appear on the slide when you add them to the Animation order.

The names refer to the type of object. When you select an object on the list, it will appear selected in the preview window.

Custom Animation in the Macintosh versions 2001 and X

In the Macintosh version, 2001, the entry of an object and an exit can be set in the animation order; each with its own effect.

If played back in another version, the exit event simply won’t happen.

In Powerpoint 2002, the version in Office XP, currently not supported at UW Oshkosh, there are both entrance and exit events in the animation order. Again, if played back in earlier versions, the exit events won’t happen.

When you have the elements you want to appear together grouped appropriately, you can begin to build your sequence.

Check the box next to the object and it will be added to the Animation Order list.

The default action for making the object appear is a mouse click, but at the lower right of the dialogue box, you can specify a time if you want the sequence to build automatically. You can combine mouse clicks and timed entry on the same slide.

In order to make the Intersection object (Freeform 2) and the word “Power” (Text 6) enter sequentially with one mouse click, choose On mouse click for Freeform 2, and Automatically after 0 (zero) seconds for Text 6.

If you decide to change the order in which you want objects to appear; click on that object in the Animation order; and then click on the up or down arrow next to the list.
Creating sequences with custom animation

Choosing effects for the entry of an object

Click on the Effects tab to bring the effects selections to the front.

You can choose an effect for each object to appear. Most of these are similar to the effects available for transitions and preset text animation.

*If you don’t choose an effect, the default is “fly from left.” This is a pretty noticeable effect and can give a carnival-like character to your presentation. Stay low key until you want to emphasize a point.*

You can select several objects on the list to apply the same effect to by holding down the Control Key while you click on them. (The option key on the Macintosh)

Several sounds are available to accompany the entrance of an object, or you can import sounds. Imported sounds are not embedded into the PowerPoint file, so you have to keep the sound file available with the same relative path when it was imported. The best plan is to create a folder and save your file there and put everything you wish to import into the folder before importing it. Then, when you copy or move the presentation, just copy or move the whole folder.

You can also choose to dim an item after the next one appears in order to keep your audience focused on the item at hand.

You can choose a color from the palette or choose a custom color. If the object involved has several colors, they all change to the new color when dimmed.

You can also choose to have the object disappear as soon as the effect is done, or to disappear on the next mouse click.

*If the object is a text block, you can choose if you want it to appear grouped by a certain level in the outline hierarchy. For example, you can have a major point and all its subpoints appear at once (1st level paragraphs), or you can have each subpoint appear as a separate item (2nd or 3rd level paragraphs).*

*In the Macintosh version, this function is on an Options tab in the Custom Animation dialogue.*

You can preview the sequence by clicking Preview (Windows) or Play (Macintosh)

Click OK to exit the dialogue box and save the settings.

Unlike the Preset text animation available in the Slide Sorter view, Custom Animation can be applied to any text block, whether created from an autotemplate or from the text block tool.

*Note: Custom animation is a property of the object it is applied to, so if you copy and paste an object from one slide to the another, it will be animated on the new slide.*
Chart Animation

Charts can also be animated.

Options are available for revealing chart elements in a variety of sequences. Most of the effects and sounds are available.

Only one effect can be applied to all elements in the chart.

*In versions 2002 and 2004, this appears as an Effect Option, but the choices are the same*

Setting Custom Animation on your Master Slide

You can apply custom animation to your master slide so you don’t have to set up each slide individually.

Usually, the animation will only apply to slides created with autotemplates that include text blocks, because that’s basically all that exists on the master slide.

Any graphics you add to an individual slide either through the autotemplates, or imported or created with the drawing tools must be animated individually.

Graphic objects on the master slide can also be animated.

You can override the animation of the text block on any individual slide, but you can’t override the animation of any graphics from the master slide.

If you had an individual slide in which you didn’t want the graphics from the master slide animated, your only option would be to hide them with Background command (found under the Format menu), and if you wanted them to appear, yet not be animated, copy and paste from the master on to the individual slide.

Since copied objects carry animation characteristics with them, you would have to go to custom animation and turn animation off for that item.

*In version 2002, you can copy the effect for text blocks or objects from the master slide to the individual slide.*